4 More details after most recent attempts
source | link

I recently ordered a French press (Bodum Kenya) and a ceramic conical burr grinder. I've tried this with two different decaf blends from Vermont Coffee Company, one which I ground at the store four days prior and one which I purchased in bean form and ground immediately before brewing.

With both cups, I experienced a weird, astringent powdery taste (arguably closer to a sensation) on the end of my tongue. I made an extra cup from the pre-ground and used hotter water (200 degrees instead of 190) and it seemed to help slightly, but it didn't fix the problem.

My methodology was as follows: heat the water, then while it's going fill my press with hot water (to heat it up, to minimize heat loss and prevent cracking) before I grind the beans. Then when the water boiled I temped the water until it hit 200 degrees even, dumped the priming water from the press, and then filled it with three scoops of coffee and roughly twelve ounces of water (my press's beaker is unmarked.)

Finally, I waited nearly four minutes before pouring.

Any idea what's going wrong here? I'm not getting much aroma or body, either. The grinder I'm using is made by Hario, and is a hand-crank conical burr grinder which received excellent reviews.

Update: As an experiment, I tried grinding a fine batch for the purposes of testing it in my bland (but unoffensive) Senseo. I learned two things: one, my brand new burr grinder has a skewed burr which screws up the consistency of the grind, and two, most of the offtastes I detected are still present. I'm drawing two conclusions:

  1. I'm using WAY more coffee for the french press than I am for the pod-brewer
  2. My grind probably isn't helping matters
  3. I do not like this roast at all anyway.

I'm returning the grinder and I will order something else. In the meantime, I've ordered a bag of whole-bean Lavazza I know I like, so that if this problem reoccurs I'll be diagnosing the issue against a blend I have specific and extensive knowledge of.

Update 2: I've substantially increased the size of my grind, and made three sequential cups with smaller and smaller grinds. At the current spot I produce a decently-aromatic 12 ounces with just under two scoops of beans, and it's completely without either the sour or powdery characters it previously suffered. It still tastes weak, though, despite a faint velvety richness which I think is indicative of what this coffee should taste like.

Increasing the amount of coffee brings back the sourness, but not the powdery taste. Interestingly, in this case the spent grounds smell quite nasty - the sour taste dialed up to 11. I'm going to finish the bag of beans and replace the grinder and see where it takes me - and once the equipment issue is resolved I'll be back to report and accept an answer.

I recently ordered a French press (Bodum Kenya) and a ceramic conical burr grinder. I've tried this with two different decaf blends from Vermont Coffee Company, one which I ground at the store four days prior and one which I purchased in bean form and ground immediately before brewing.

With both cups, I experienced a weird, astringent powdery taste (arguably closer to a sensation) on the end of my tongue. I made an extra cup from the pre-ground and used hotter water (200 degrees instead of 190) and it seemed to help slightly, but it didn't fix the problem.

My methodology was as follows: heat the water, then while it's going fill my press with hot water (to heat it up, to minimize heat loss and prevent cracking) before I grind the beans. Then when the water boiled I temped the water until it hit 200 degrees even, dumped the priming water from the press, and then filled it with three scoops of coffee and roughly twelve ounces of water (my press's beaker is unmarked.)

Finally, I waited nearly four minutes before pouring.

Any idea what's going wrong here? I'm not getting much aroma or body, either. The grinder I'm using is made by Hario, and is a hand-crank conical burr grinder which received excellent reviews.

Update: As an experiment, I tried grinding a fine batch for the purposes of testing it in my bland (but unoffensive) Senseo. I learned two things: one, my brand new burr grinder has a skewed burr which screws up the consistency of the grind, and two, most of the offtastes I detected are still present. I'm drawing two conclusions:

  1. I'm using WAY more coffee for the french press than I am for the pod-brewer
  2. My grind probably isn't helping matters
  3. I do not like this roast at all anyway.

I'm returning the grinder and I will order something else. In the meantime, I've ordered a bag of whole-bean Lavazza I know I like, so that if this problem reoccurs I'll be diagnosing the issue against a blend I have specific and extensive knowledge of.

I recently ordered a French press (Bodum Kenya) and a ceramic conical burr grinder. I've tried this with two different decaf blends from Vermont Coffee Company, one which I ground at the store four days prior and one which I purchased in bean form and ground immediately before brewing.

With both cups, I experienced a weird, astringent powdery taste (arguably closer to a sensation) on the end of my tongue. I made an extra cup from the pre-ground and used hotter water (200 degrees instead of 190) and it seemed to help slightly, but it didn't fix the problem.

My methodology was as follows: heat the water, then while it's going fill my press with hot water (to heat it up, to minimize heat loss and prevent cracking) before I grind the beans. Then when the water boiled I temped the water until it hit 200 degrees even, dumped the priming water from the press, and then filled it with three scoops of coffee and roughly twelve ounces of water (my press's beaker is unmarked.)

Finally, I waited nearly four minutes before pouring.

Any idea what's going wrong here? I'm not getting much aroma or body, either. The grinder I'm using is made by Hario, and is a hand-crank conical burr grinder which received excellent reviews.

Update: As an experiment, I tried grinding a fine batch for the purposes of testing it in my bland (but unoffensive) Senseo. I learned two things: one, my brand new burr grinder has a skewed burr which screws up the consistency of the grind, and two, most of the offtastes I detected are still present. I'm drawing two conclusions:

  1. I'm using WAY more coffee for the french press than I am for the pod-brewer
  2. My grind probably isn't helping matters
  3. I do not like this roast at all anyway.

I'm returning the grinder and I will order something else. In the meantime, I've ordered a bag of whole-bean Lavazza I know I like, so that if this problem reoccurs I'll be diagnosing the issue against a blend I have specific and extensive knowledge of.

Update 2: I've substantially increased the size of my grind, and made three sequential cups with smaller and smaller grinds. At the current spot I produce a decently-aromatic 12 ounces with just under two scoops of beans, and it's completely without either the sour or powdery characters it previously suffered. It still tastes weak, though, despite a faint velvety richness which I think is indicative of what this coffee should taste like.

Increasing the amount of coffee brings back the sourness, but not the powdery taste. Interestingly, in this case the spent grounds smell quite nasty - the sour taste dialed up to 11. I'm going to finish the bag of beans and replace the grinder and see where it takes me - and once the equipment issue is resolved I'll be back to report and accept an answer.

3 added 766 characters in body
source | link

I recently ordered a French press (Bodum Kenya) and a ceramic conical burr grinder. I've tried this with two different decaf blends from Vermont Coffee Company, one which I ground at the store four days prior and one which I purchased in bean form and ground immediately before brewing.

With both cups, I experienced a weird, astringent powdery taste (arguably closer to a sensation) on the end of my tongue. I made an extra cup from the pre-ground and used hotter water (200 degrees instead of 190) and it seemed to help slightly, but it didn't fix the problem.

My methodology was as follows: heat the water, then while it's going fill my press with hot water (to heat it up, to minimize heat loss and prevent cracking) before I grind the beans. Then when the water boiled I temped the water until it hit 200 degrees even, dumped the priming water from the press, and then filled it with three scoops of coffee and roughly twelve ounces of water (my press's beaker is unmarked.)

Finally, I waited nearly four minutes before pouring.

Any idea what's going wrong here? I'm not getting much aroma or body, either. The grinder I'm using is made by Hario, and is a hand-crank conical burr grinder which received excellent reviews.

Update: As an experiment, I tried grinding a fine batch for the purposes of testing it in my bland (but unoffensive) Senseo. I learned two things: one, my brand new burr grinder has a skewed burr which screws up the consistency of the grind, and two, most of the offtastes I detected are still present. I'm drawing two conclusions:

  1. I'm using WAY more coffee for the french press than I am for the pod-brewer
  2. My grind probably isn't helping matters
  3. I do not like this roast at all anyway.

I'm returning the grinder and I will order something else. In the meantime, I've ordered a bag of whole-bean Lavazza I know I like, so that if this problem reoccurs I'll be diagnosing the issue against a blend I have specific and extensive knowledge of.

I recently ordered a French press (Bodum Kenya) and a ceramic conical burr grinder. I've tried this with two different decaf blends from Vermont Coffee Company, one which I ground at the store four days prior and one which I purchased in bean form and ground immediately before brewing.

With both cups, I experienced a weird, astringent powdery taste (arguably closer to a sensation) on the end of my tongue. I made an extra cup from the pre-ground and used hotter water (200 degrees instead of 190) and it seemed to help slightly, but it didn't fix the problem.

My methodology was as follows: heat the water, then while it's going fill my press with hot water (to heat it up, to minimize heat loss and prevent cracking) before I grind the beans. Then when the water boiled I temped the water until it hit 200 degrees even, dumped the priming water from the press, and then filled it with three scoops of coffee and roughly twelve ounces of water (my press's beaker is unmarked.)

Finally, I waited nearly four minutes before pouring.

Any idea what's going wrong here? I'm not getting much aroma or body, either. The grinder I'm using is made by Hario, and is a hand-crank conical burr grinder which received excellent reviews.

I recently ordered a French press (Bodum Kenya) and a ceramic conical burr grinder. I've tried this with two different decaf blends from Vermont Coffee Company, one which I ground at the store four days prior and one which I purchased in bean form and ground immediately before brewing.

With both cups, I experienced a weird, astringent powdery taste (arguably closer to a sensation) on the end of my tongue. I made an extra cup from the pre-ground and used hotter water (200 degrees instead of 190) and it seemed to help slightly, but it didn't fix the problem.

My methodology was as follows: heat the water, then while it's going fill my press with hot water (to heat it up, to minimize heat loss and prevent cracking) before I grind the beans. Then when the water boiled I temped the water until it hit 200 degrees even, dumped the priming water from the press, and then filled it with three scoops of coffee and roughly twelve ounces of water (my press's beaker is unmarked.)

Finally, I waited nearly four minutes before pouring.

Any idea what's going wrong here? I'm not getting much aroma or body, either. The grinder I'm using is made by Hario, and is a hand-crank conical burr grinder which received excellent reviews.

Update: As an experiment, I tried grinding a fine batch for the purposes of testing it in my bland (but unoffensive) Senseo. I learned two things: one, my brand new burr grinder has a skewed burr which screws up the consistency of the grind, and two, most of the offtastes I detected are still present. I'm drawing two conclusions:

  1. I'm using WAY more coffee for the french press than I am for the pod-brewer
  2. My grind probably isn't helping matters
  3. I do not like this roast at all anyway.

I'm returning the grinder and I will order something else. In the meantime, I've ordered a bag of whole-bean Lavazza I know I like, so that if this problem reoccurs I'll be diagnosing the issue against a blend I have specific and extensive knowledge of.

    Tweeted twitter.com/#!/StackCooking/status/287408636253315072
2 added 115 characters in body
source | link

I recently ordered a French press (Bodum Kenya) and a ceramic conical burr grinder. I've tried this with two different decaf blends from Vermont Coffee Company, one which I ground at the store four days prior and one which I purchased in bean form and ground immediately before brewing.

With both cups, I experienced a weird, astringent powdery taste (arguably closer to a sensation) on the end of my tongue. I made an extra cup from the pre-ground and used hotter water (200 degrees instead of 190) and it seemed to help slightly, but it didn't fix the problem.

My methodology was as follows: heat the water, then while it's going fill my press with hot water (to heat it up, to minimize heat loss and prevent cracking) before I grind the beans. Then when the water boiled I temped the water until it hit 200 degrees even, dumped the priming water from the press, and then filled it with three scoops of coffee and roughly twelve ounces of water (my press's beaker is unmarked.)

Finally, I waited nearly four minutes before pouring.

Any idea what's going wrong here? I'm not getting much aroma or body, either. The grinder I'm using is made by Hario, and is a hand-crank conical burr grinder which received excellent reviews.

I recently ordered a French press (Bodum Kenya) and a ceramic conical burr grinder. I've tried this with two different decaf blends from Vermont Coffee Company, one which I ground at the store four days prior and one which I purchased in bean form and ground immediately before brewing.

With both cups, I experienced a weird, astringent powdery taste (arguably closer to a sensation) on the end of my tongue. I made an extra cup from the pre-ground and used hotter water (200 degrees instead of 190) and it seemed to help slightly, but it didn't fix the problem.

My methodology was as follows: heat the water, then while it's going fill my press with hot water (to heat it up, to minimize heat loss and prevent cracking) before I grind the beans. Then when the water boiled I temped the water until it hit 200 degrees even, dumped the priming water from the press, and then filled it with three scoops of coffee and roughly twelve ounces of water (my press's beaker is unmarked.)

Finally, I waited nearly four minutes before pouring.

Any idea what's going wrong here? I'm not getting much aroma or body, either.

I recently ordered a French press (Bodum Kenya) and a ceramic conical burr grinder. I've tried this with two different decaf blends from Vermont Coffee Company, one which I ground at the store four days prior and one which I purchased in bean form and ground immediately before brewing.

With both cups, I experienced a weird, astringent powdery taste (arguably closer to a sensation) on the end of my tongue. I made an extra cup from the pre-ground and used hotter water (200 degrees instead of 190) and it seemed to help slightly, but it didn't fix the problem.

My methodology was as follows: heat the water, then while it's going fill my press with hot water (to heat it up, to minimize heat loss and prevent cracking) before I grind the beans. Then when the water boiled I temped the water until it hit 200 degrees even, dumped the priming water from the press, and then filled it with three scoops of coffee and roughly twelve ounces of water (my press's beaker is unmarked.)

Finally, I waited nearly four minutes before pouring.

Any idea what's going wrong here? I'm not getting much aroma or body, either. The grinder I'm using is made by Hario, and is a hand-crank conical burr grinder which received excellent reviews.

1
source | link