0

The plunger or stem in my Cresomo 101oz Stainless Steel Vacuum Airpot is stuck after I cleaned it once after receiving and taking out of the package to wash it.

I've heard it suggested that I could get it out of there by heating it up; and I've also heard that I could use a pair of tongs to pull it out; but neither has worked, and the rubber plunger remains lodged below the hole in the middle of it.

Both of the people I talked to who gave me the advice above, work in the Food and Beverage Industry.

What else can I do to pull that plunger out of it so that it can be used for the first time?

3
  • It sounds as if it's broken to me, wend it back under guarantee and get a replacement.
    – GdD
    Nov 22, 2021 at 8:42
  • are you able to provide a picture that shows where it is stuck?
    – Mr Shane
    Dec 20, 2021 at 10:57
  • I fixed it; I used a pair of needle nosed pliers.
    – leeand00
    Dec 20, 2021 at 16:29

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.