Loved my tramontina 3 piece induction system from Costco until this happened. Was boiling some eggs as I do every morning and had done for 9 days in a row with this system. This morning I might have had the temperature a little higher but not much more. When the water came to a rolling boil I put 2 eggs in. When it was time to pull them out I shut off the cooktop and went to pull off the lid, but I couldn't because it was stuck. I thought that maybe it needed to cool down so I left it alone now 12 hours. However the lid is still stuck to the pot. I do not wish to force it. I have even held it upside down as pictured.

enter image description here

  • 2
    since you're still getting answers on this question, is there any chance you could come back and tell what worked or accept one of the answers? I'm curious to know how did you solve it.
    – Luciano
    Commented Jun 29, 2020 at 15:27

6 Answers 6


It seems really unlikely it somehow rusted shut or anything like that while you were boiling, so it seems most likely that there's just a partial vacuum inside. While boiling, it'd have been full of hot air and steam, and now that's all cooled down, and the steam has condensed, so it could shrink down you end up with low pressure inside sucking the lid down. It's a bit surprising that the seal is good enough to hold the pressure for this long, though!

In any case, if that's it, assuming there's still liquid in it, I'd try just heating it again. That would increase the pressure inside, hopefully back up to normal, enough to let you get the lid off. I'd also try twisting and angling it, because if that's it, all you need is a tiny opening to equalize pressure.

If this does turn out to have been the issue, you could probably avoid it in the future by opening the lid immediately when it's done.

  • 3
    I've had that happen to me, and a vacuum is exactly what happened. I ended up prying it apart carefully, with some clamps and tools, as I had unfortunately, boiled it completely dry. My mother in law also did this as she lit a giant pan on fire, and I threw a lid on before she burned her kitchen down as she starting screaming and moving it around her very flammable kitchen. So yeah, this can totally happen. If there's still liquid in there, then heating it would be my first solution too.
    – talon8
    Commented Oct 16, 2017 at 15:57
  • A variant of this is how my mother cracked a ceramic cooktop...
    – Marti
    Commented Oct 16, 2017 at 17:07
  • 2
    @talon8 Thanks, that's helpful, I edited to clarify that heating is for if there's water in it. (It looked like probably so, given the droplets and that it was boiling eggs, not just a small amount of water.) If it's dry... yeah, I'm impressed you managed to pry it open like that! The only other thing I thought of was gentle heating and maybe even freezing, in hopes that the two parts would expand/contract differently from the glass lid, possibly to the point of opening enough of a crack for a tiny bit of air flow.
    – Cascabel
    Commented Oct 16, 2017 at 18:22
  • I don't think that's a glass lid? I did rip the handle off the lid. But the pot still works. I suspect given two metal surfaces... I don't know that you could expand the base sufficiently without also expanding the lid to break the seal. But In my case, my next choice was throwing the whole thing away.
    – talon8
    Commented Oct 17, 2017 at 17:08
  • 1
    Most pot lids have a small hole in them for exactly this reason
    – SnakeDoc
    Commented Jun 26, 2020 at 22:20

I found an easy way to get the lid off after it happened to me with a pot of brown rice. I had set a timer, so I was pretty sure there wasn't any water left in the pot which made me reluctant to heat it back up. Instead I boiled a different pot of water and set the stuck pot on top of it. Within a couple of minutes the top released without any problems or noise.


So this just happened to us. I found this site and learned it was a vacuum problem. So I used a small blade screwdriver to pry the rubber seal away from the glass at one point. Voila! Vacuum broken, lid comes off.


We have this pot and have had the lid stick every time we use it. I'm thinking; drill a small hole in the lid. Have used a small thin knife to open the lid before but have almost stabbed myself doing it that way. Can't believe this problem hasn't been corrected by COSTCO.


Just had my first experience using this product and trapped my dinner. I did not burn my kitchen down but the thought did come up. I thumped the pot edge in a stainless sink till the vacuum was broken.

Customer Service did say to heat it up but when the trapped item inside is burning this seems dangerous to me.

  • 1
    I see this as an answer. It contains two suggestions (thump the pot edge or heat it up) and testimony that one of them worked.
    – rumtscho
    Commented Jun 30, 2020 at 7:48

Carefully slide a single edge razor blade inbetween the lid and pot and it will release.

  • 2
    I would not even recommend this with safety glasses on - the forces are just too great to toy around with breakable razor blades.
    – user34961
    Commented Jan 13, 2019 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.